欢迎光临, 访客. 请先 登入註册一个帐号.
七月 16, 2020, 11:03:51 下午
19594 文章 在 3864 主题 由 4580 会员
最新註册会员: aa123aa1
LifeType 中文开发论坛  |  开发  |  模版设计  |  模版设计精华区  |  绿色风格模版 [plog1.0] « 上篇主题 下篇主题 »
页: 1 [2]
作者 主题: 绿色风格模版 [plog1.0]  (阅读 52477 次)
Ameng
访客
« 回覆文章 #15 于: 六月 02, 2005, 01:06:07 下午 »

怎么整合的阿,能否把经验分享一下?
已记录
安.媚媚猫
新手见习
*
文章: 2


检视个人资料
« 回覆文章 #16 于: 八月 01, 2005, 02:07:41 下午 »

可是,为什么下来后,效果跟DEMO的很不一样呢?
哪里有你演示的那个模板呢?谢谢谢谢,急用
已记录
junyang296
初级会员
**
文章: 52


检视个人资料
« 回覆文章 #17 于: 八月 01, 2005, 08:39:57 下午 »

我也希望使用,谢谢!
已记录
sunkit
初级会员
**
文章: 79


检视个人资料
« 回覆文章 #18 于: 八月 02, 2005, 01:44:42 下午 »

引用自: lurking
由于和论坛整合,所以链接更新:

http://www.712100.com/blog/index.php?blogId=4


于妁上blog中资源中心下载的green.rar,

解压时出现错误.

烦请修正.
已记录
ted
一般会员
***
文章: 103


检视个人资料
« 回覆文章 #19 于: 十月 26, 2005, 08:04:22 上午 »

我在套用这个 template后大致都没问题,

我没有修改任何东西

但使用 IE 浏览时
在点选 文章分类后, 右边所有的东西都会往下掉
点选日历上的任何日期时, 也会如此

请问有人有同样的问题吗?


使用 Firefox 浏览则没这问题
请问要修改那个地方才能让IE 也能正常浏览呢?


我的网址: http://163.13.32.107:8080/plog/index.php?blogId=7
已记录

OS: windows server 2003
Apache Web Server Version 2.2.2
PHP Script Language Version 5.1.4
MySQL Database Version 5.0.22
markwu
系统管理员
超级会员
*****
文章: 3928


Mark Wu


检视个人资料 个人网站
« 回覆文章 #20 于: 十月 26, 2005, 09:24:50 上午 »

我在套用这个 template后大致都没问题,

我没有修改任何东西

但使用 IE 浏览时
在点选 文章分类后, 右边所有的东西都会往下掉
点选日历上的任何日期时, 也会如此

请问有人有同样的问题吗?


使用 Firefox 浏览则没这问题
请问要修改那个地方才能让IE 也能正常浏览呢?


我的网址: http://163.13.32.107:8080/plog/index.php?blogId=7


Hi taihung:

看起来没问题阿?

Mark
已记录

ted
一般会员
***
文章: 103


检视个人资料
« 回覆文章 #21 于: 十月 26, 2005, 09:46:27 上午 »

是吗 开怀大笑

我试了二台电脑的 IE都有问题说 吐舌头

谢谢 Mark, 我会再试试其他的电脑看看


ps. 我的画面如附图, 另,我的系统字型都是预设大小
已记录

OS: windows server 2003
Apache Web Server Version 2.2.2
PHP Script Language Version 5.1.4
MySQL Database Version 5.0.22
markwu
系统管理员
超级会员
*****
文章: 3928


Mark Wu


检视个人资料 个人网站
« 回覆文章 #22 于: 十月 26, 2005, 12:34:00 下午 »

我看到是正常的阿!

Mark
已记录

ted
一般会员
***
文章: 103


检视个人资料
« 回覆文章 #23 于: 十月 26, 2005, 02:27:30 下午 »

谢谢 Mark!

我看你的画面是在首页, 这在我这儿也正常

在若继续点 右边的 文章分类中 任一分类的话

结果就我画面 右边 所有的东西会往下掉

请 Mark 请试看看, (用IE)

如果会往下掉的话, 是不是得要修改CSS 了?
已记录

OS: windows server 2003
Apache Web Server Version 2.2.2
PHP Script Language Version 5.1.4
MySQL Database Version 5.0.22
markwu
系统管理员
超级会员
*****
文章: 3928


Mark Wu


检视个人资料 个人网站
« 回覆文章 #24 于: 十月 26, 2005, 03:11:02 下午 »

谢谢 Mark!

我看你的画面是在首页, 这在我这儿也正常

在若继续点 右边的 文章分类中 任一分类的话

结果就我画面 右边 所有的东西会往下掉

请 Mark 请试看看, (用IE)

如果会往下掉的话, 是不是得要修改CSS 了?


瞭解了!

另外,拜託下次有问题时,可以先把你改过的模版贴上来吗?或是至少说明你改过些什么?要不然, 我还要透过你的显现画面来反推你到底改过了什么,这真的很浪费时间的一件事。重点是,我还不一定猜的对 .....  伤心

Anyway 回到正题。我在『猜』你在post.template 中把 {$post->getText()} 改为 {$post->getText()|truncate:30:"...":true},所以造成截断了html tag,就变成某些 tag 没有 close,模版就跑掉了。

解决方式:
1. 改回  {$post->getText()}
2. 或是改为 {$post->getText()|strip_tags|truncate:30:"...":true},也就是在截断之前先把 html tag 都移除。有关 smarty 更深入的用法,请参考:http://smarty.php.net/manual/en/language.modifiers.php

Mark
« 最后编辑时间: 十月 26, 2005, 03:18:28 下午 由 markwu » 已记录

ted
一般会员
***
文章: 103


检视个人资料
« 回覆文章 #25 于: 十月 27, 2005, 08:01:25 上午 »

再次谢谢 Mark 的回覆

其实我只是把这个模版直接拿来用,什么地方也没改, 然后就问题出现了


依 Mark 的建议, 不论是 {$post->getText()} 或 {$post->getText()|strip_tags|truncate:30:"...":true}
结果都还是一样

唉...
已记录

OS: windows server 2003
Apache Web Server Version 2.2.2
PHP Script Language Version 5.1.4
MySQL Database Version 5.0.22
markwu
系统管理员
超级会员
*****
文章: 3928


Mark Wu


检视个人资料 个人网站
« 回覆文章 #26 于: 十月 27, 2005, 05:16:59 下午 »

你打开http://163.13.32.107:8080/plog/index.php?op=Default&postCategoryId=13&blogId=7,这是你出问题的页面,他的原始码是:

程式码:
<font size="2">
<h2><strong><font size="2">Consumers in Europe</font></strong></h2>
<h3><font size="2">Facts and figures : data 1999-2004</font></h3>
<p><font size="2"></font></p>
<p><font size="2"><strong>Publication Year</strong>: 2005</font></p></font>
<p><font...
注意最后的 <font...

另外,这是你的 http://163.13.32.107:8080/plog/index.php?op=ViewArticle&articleId=56&blogId=7 正常的文章,他的原始码是:

程式码:
<font size="2">
<h2><strong><font size="2">Consumers in Europe</font></strong></h2>
<h3><font size="2">Facts and figures : data 1999-2004</font></h3>
<p><font size="2"></font></p>
<p><font size="2"><strong>Publication Year</strong>: 2005</font></p></font>
<p><font size="2">此份出版品提供欧盟二十五国境内消费者消费取向,花费,满意度等相关数据</font></p>
<p><font size="2"><a href="http://bookshop.eu.int/eGetRecords?Template=Test_EUB/en_index" target="_blank">详细书目与全文</a></font></p><br/>

你有注意到吗?这是正常的。

所以我才猜测你的模版使用了这样的技巧来截断文字 {$post->getText()|truncate:30:"...":true}。

因为只有用 truncate 才会造成这样的问题。你可以搜寻模版,看哪里出现 truncate 这个字。

Anyway, 这个部分的 template 通常在post.template。改完后,记得清 Cache。

另外,不要唉声嘆气的。该嘆气的是我才对耶 .... 唉   吐舌头

Mark
« 最后编辑时间: 十月 27, 2005, 05:22:09 下午 由 markwu » 已记录

ted
一般会员
***
文章: 103


检视个人资料
« 回覆文章 #27 于: 十月 27, 2005, 07:48:15 下午 »

我针对 Green 这个模版中的档案做搜寻

发现 {$post->getText()|truncate:30:"...":true} 出现在 main.template, 而不是 post.template

改为{$post->getText()} 便可正常显示了

谢谢 Mark 的耐心


因为我是直接下载 Green 模版使用, 没有做任何更改
难道都没人遇到与我相同的情况吗??

已记录

OS: windows server 2003
Apache Web Server Version 2.2.2
PHP Script Language Version 5.1.4
MySQL Database Version 5.0.22
页: 1 [2]
LifeType 中文开发论坛  |  开发  |  模版设计  |  模版设计精华区  |  绿色风格模版 [plog1.0] « 上篇主题 下篇主题 »
    前往: